Managed by the FaxBack Support Team
This article applies to:
NET SatisFAXtion Server All versions
OS: All



PROBLEM

The NET SatisFAXtion Fax Server uses a Windows user account to load the NET SatisFAXtion service. NET SatisFAXtion requires local Administrative privileges. Sometimes changing the user account for the service is needed, however brings its own set of challenges.

CAUSE

Network Administrative changes, personnel changes, User account first used to install is not the user the server will use permanently, forgot password to previous user account, other.

SOLUTION

The windows user account chosen to change to, must have local Administrator privileges and network rights where network resources are used by the fax server. There are several things to consider when changing the user account, as you are also changing the windows profile used by the NET SatisFAXtion service. It is best to login to the desktop using the same user account you are setting up for the service. This way you can test each function and solve any problems before loading the service.
Areas that can/will be affected by changing the Service Account User.
  1. Document Conversion
  2. Fax Export
  3. AutoPrint
  4. Virus Software exclusions
  5. Windows Firewall exclusions

Document Conversion:
Applications launched by the document conversion process are often profile based. This will cause outbound server side conversion to fail because applications will be prompting for profile initials, for the user to agree to a license agreement, etc. NOTE: Office applications prompt for initials when a new user launches an application as a way of associating that profile with Office Applications. Single initials do not work, even if presented with only one initial when prompted. Always use two initials. Acrobat reader will prompt to agree to a license agreement. For more information see Document Conversion errors: Causes and Solutions
Fax Export:
Fax Export can be configured to write exported faxes to a UNC path on your network or even on a WAN. Make sure Service User Account has permissions to these folders. For more information see Export faxes to a network share
Autoprint:
You may need to install print drivers for the new Service User Account on this new Windows Profile. Check AutoPrint settings on the old profile and the printers installed, so the same printers exist on the new profile.
Virus Software Exclusions:
Check any current exclusions in your virus software to match them if needed, in the new windows user profile.
Windows Firewall Exclusions:
All necessary exclusions for a default NET SatisFAXtion server are done programmatically, so any customer changes you may have had to make, should be repeated for the new Windows user profile, if needed.

Changing the Windows Service Account user:
Make sure you have already created the new Windows User Account and performed the above steps.
  • Run Start - Programs - NET SatisFAXtion - Change Server Settings
  • Uncheck, then recheck the selection for Run fax server as an automatic start service (recommended)
RunFaxServerAsService.PNG
  • After being prompted to stop the NET SatisFAXtion service (if currently loaded) a prompt to login a Service Account User is presented.
  • Enter the new Service Account User and password, then click OK
ServiceLogin.PNG
  • Click OK on the Change Server Settings screen and restart the fax server service, now using the new account.
  • Test as needed for Document Conversion, Fax Export, AutoPrinting, etc. to insure your new windows user account has all the necessary rights and third party applications have been properly setup.

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