Managed by the FaxBack Support Team
This article applies to:
NET SatisFAXtion 8.6 and 8.7
OS: Server 2008 R2

PROBLEM

During the server load, the server crashes at loading the IP Fax driver on Windows 2008 R2
Application Event log displays (example)
Faulting application NetSatisFAXtion.exe, version 8.6.5233.924, time stamp 0x4ba15031, faulting module IP_FAX.dll, version 0.0.0.0, time stamp 0x4e1dd72b, exception code 0xc0000005, fault offset 0x0000626d, process id 0x%9, application start time 0x%10.

CAUSE

A UDP port was forcably opened by another application or process during the load process. IP_Fax.dll checks for open ports before loading and binding to a port and at the time the port was checked, it was not in use. Shortly after the port is allocated, another process attached to the port. It's possible McAffee Anti-virus is involved, however difinitive testing has not yet been completed.

SOLUTION

Change the start_port_number for IP_Fax.dll to a higher number
  • Open REGEDIT
  • Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\FaxBack\IP_FAX
  • In the global IP_FAX key create a new dword value named start_port_number and set the value to a new port number that is not used.
  • Start the NET SatisFAXtion fax server service

start_port_number.JPG

Registry configuration reference:
start_port_number
[dword 1–65535]: First UDP port to allocate for RTP and T.38.
Default: 49152


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