Managed by the FaxBack Support Team
This article applies to NET SatisFAXtion 8.6, 8.7
OS: Any

PROBLEM

Error found in Monitor Workflows logging.
Example:
ID = 6287
Type = Error
Time = 13:06:04.245 5/23/2012
Source = Export_Core
Class = Log_Write
Message = System.Data.DataException: Unable to write new row: Invalid column name 'dial_seconds'.
Invalid column name 'v21_frame_error_count'.
Invalid column name 'ecm_frame_error_count'.
Invalid column name 'rtp_count'.
Invalid column name 'rtn_count'.
Invalid column name 'dis'.
Invalid column name 'nsf1'.
Invalid column name 'nsf2'.
Invalid column name 'sip_call_id'.
at System.Workflow.ComponentModel.ThrowActivity.Execute(ActivityExecutionContext executionContext)
at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)
at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)
at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)
at System.Workflow.Runtime.Scheduler.Run()
Category =
DataType = None
Data =

Some symptoms are:
  • Export jobs fail to leave the inbox as viewed from the Administration program
  • Reporting does not show any new data since upgrading
  • Export jobs do not reach their destination folder

CAUSE

SQL Database was not updated with new rows or column names during an upgrade.

SOLUTION

  1. Go to the "[DRIVE:]\NET SatisFAXtion CD Image" folder, then to the "NET SatisFAXtion" folder.
  2. Double click on "CreateSQLDatabases.exe"
  3. Click the "Open Template" button
  4. Open [DRIVE:]\NET SatisFAXtion CD Image\NET SatisFAXtion\CreateSQLDatabases.xml
  5. Click the "Fix" Button
  6. Restart the NET SatisFAXtion service

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