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How To - Remove Temporary Files Left By Acrobat Reader


This article applies to NET SatisFAXtion 8.5 through 9.0
OS: Windows XP, 2000, 2003, 2008, 2012, Windows 7 and Windows 8

SYMPTOM

Server side PDF Conversions fail with Error code 4246 (01096) - Timeout waiting for conversion application to print: The application didn't print in a timely fashion.

PROBLEM

Using Adobe Acrobat Reader (any version) to convert PDF attachments to a faxable image, can leave temp files behind that degrade the performance of the fax server, and contribute to conversion errors. This only affects PDF attachments.

CAUSE

The build-up of temp files causes PDF conversions to slow down and over time, fail completely. Acrobat Reader writes a temp file containing the font of each PDF opened and printed. Each time Acrobat writes a new temp file, it must traverse the folder, reading each file name, then write the next sequential file. This process slows a little each time as the number of files grows. When this count gets up to many thousands, timeout errors start to occur. A warning sign is often that higher page count PDFs will fail with timeout errors.
In severe cases, every PDF conversion can fail with:
4246 (01096) - Timeout waiting for conversion application to print: The application didn't print in a timely fashion.

The reason Acrobat Reader does not always clean up temp files used when opening and/or printing is not known.

SOLUTION

Maintain the number of files in the temp folder. To accomplish this, you must first locate the proper temp folder. Acrobat Reader uses a windows user's temp folder. NET SatisFAXtion uses a Windows User account to load its service, and does so because of the document conversion process and interaction with 3rd party applications, such as Acrobat Reader.

Locate the Windows User account

The Windows service user account can be found by looking at the Log On tab of the NET SatisFAXtion service. See NET SatisFAXtion Windows service user account for Details.

Locate the Windows User temp folder


Use Caution: Remember the {WindowsUser} folder is the user the NET SatisFAXtion service account uses and not necessarily the Windows account you are logged into the machine as.

Windows XP, 2000, 2003
C:\Documents and Settings\{WindowsUser}\Local Settings\Temp

Windows 7, 8, 2008, 2012
C:\Users\{Windows.user}\AppData\Local\Temp

Deleting the Temp Files

It's best to perform this task from a command prompt. Often using Windows file explorer with large numbers of files can be very slow, or in some cases even crash Windows explorer.

1. Stop the NET SatisFAXtion service and make sure Acrobat Reader is closed.

2. Open a command prompt

Note: AppData is often a hidden folder. You can manually type "AppData", then see the Local and Temp folders from Windows file explorer or the command prompt.


Also in some cases, Acrobat has set the hidden attribute on these files. To show all *.tmp files, from a command prompt, in the proper folder, Issue a:

3. ATTRIB -H *.TMP

attrib-h.PNG

4. Issue a DEL *.TMP from the temp folder to remove the temp files
5. Start the NET SatisFAXtion service

Scheduling an automatic deletion of Acrobat temp files

If this is a problem that occurs often, it's recommended that you have a Network Admin create a scheduled script and schedule it to run periodically, making sure that the scheduled time is during the low traffic periods, or even on weekends. The period of time between scheduled events, should be based on how often you run into groups of error code 4246 (01096), and divide that time by 3.

Related Articles

Troubleshooting Document Conversion errors
Adobe XI Pre-Conversion Errors

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